Saarland University
Lehrstuhl für Automatisierungstechnik

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> How to post good questions, This topic describes how to formulate questions in order to get good b
wagner
post Mar 6 2008, 09:10 PM
Post #1


Administrator
***

Group: Root Admin
Posts: 121
Joined: 13-March 06
Member No.: 1



Dear forum users,

sometimes questions remain without any answer for quite a long time. This might be due to several reasons, e.g.:
  • the question is not Modelica related,
  • the problem of the question is that specific that nobody in the forum knows the answer,
  • the question is too general (e.g. "how to write a fluid library in Modelica?"),
  • the question is about Modelica implementation issues but no (ready to use) example model is given.
I think the reasons why these types of questions often don't get answer is quite obvious but still many types of these are posted to the forum. Thus, here are some guidelines on how to ask "good" questions.
  1. Put your question in the correct forum. Tool specific issues (e.g. how do I open a file in tool XY) should be put in the forum dedicated to this tool.
  2. Clearly state the application domain of your question! E.g. if you have a topic related to fluid dynamics, state this in the topic title, but at least in the topic description.
  3. Even if your topic is about plain physical modelling, not necessarily related to Modelica, formulate your questions using Modelica syntax, as veryone in the forum will understand this without ambiguities. If you want to describe a structural problem don't try to draw ASCII figures. Instead, use a graphical tool of your choice and draw the structure of your system and then attach a file in .png or .jpg format. Of course, providing a Modelica model is always the best choice as everyone will know what the elements in the Model will mean.
  4. If you want to discuss problems related to the Modelica implementation of a model (e.g. unbalanced models) it is not sufficient to write
    QUOTE
    I have a model about an electrical system and when I check a single component everything is fine but when I check a composit model, check fails with the "error x unknows and y equation". Who can help me?
    . How can the forum users guess what your (probably wrong) implementation looks like? You need to provide the model itself to get some useful hints. Even more, you should provide a ready to use package that one just loads into his Modelica tool and easily can reproduce the error or problem you have. If you don't want to provide your complete model (e.g. for intelectual property reasons) reduce your models to the essential parts. Just keep in mind that other forum users don't want to translate your prosa description of the problem to Modelica code as this is time consuming and error prone.
Keeping these these guidelines in mind when you ask a question dramatically increases your chance to get a solution of your problem for free!
User is offlineProfile CardPM
Go to the top of the page
+Quote Post

Reply to this topicStart new topic
2 User(s) are reading this topic (2 Guests and 0 Anonymous Users)
0 Members:

 



Lo-Fi Version Time is now: 23rd November 2017 - 08:35 PM