Saarland University
Lehrstuhl für Automatisierungstechnik

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> OpenModelica takes forever to draw connections or rename models
tgraeber
post Jun 20 2013, 08:40 AM
Post #1


Newbie
*

Group: Members
Posts: 2
Joined: 19-June 13
Member No.: 625,874



Hi,

I am working on a drive train model in OpenModelica and have set up the engine so far. I used the cylinder element from the examples which is used in the EngineV6.

Now it happens that every time I work in the model it takes OMedit forever to change the model. I just draw a connection between two blocks and it is knocked out for 30 seconds. I rename a model and it takes like ten minutes until I can go on working. Also the simulation takes forever. Compiling seems to be fast, like one or two minutes, Simulation takes maybe one minute, but after that (I guess post processing the results) I have to wait approximately 15 minutes even though I took only 500 result points.

Why is the program that slow? I suppose it is not the computer: Quad Core 2GHz, 8Gig Ram... Can I change the settings somewhere that it works faster? E.g. it seems the program does a model check every single time I draw a connection, can I opt that out?

Thanks in advance
T
User is offlineProfile CardPM
Go to the top of the page
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



Lo-Fi Version Time is now: 16th July 2019 - 10:26 AM